Marshall dsl1 chopped sound muted ,any help?

Discussion in 'The Workbench' started by vampirion78, Nov 27, 2021.

  1. vampirion78

    vampirion78 New Member

    Joined:
    Nov 27, 2021
    Messages:
    4
    Likes Received:
    1
    Hello guys,last month I got a new marshall dsl1 tube amp, problem is the little amp almost never had a session with no problems, at first I thought it was my crappy old guitar or some of my cables but after trying 3 new cables new power cord and brand new guitar on it I still have some times chopped sound or a few dozens of seconds muted sound, what could it be causing the problem and is there anything I haven't tried yet? I'm getting desperate here and I'm seriously thinking of sending the amp back to thomman, thanks in advance, any kind of help would be appreciated
     
  2. gregr

    gregr Well-Known Member

    Joined:
    Jul 30, 2014
    Messages:
    766
    Likes Received:
    851
    Sounds like it could be a bad relay or something wrong with part of the switching system (assuming the amp uses a relay to mute between switching). Do you have a problem when you plug into the back of the amp? If it’s still under warranty send it back.
     
    PelliX likes this.
  3. vampirion78

    vampirion78 New Member

    Joined:
    Nov 27, 2021
    Messages:
    4
    Likes Received:
    1
    Same sound problem goes when I plug my Head phones to the emulated out, I have already asked for service or replacement, I just thought maybe I'm missing something obvious because I'm not very experienced with gear
     
  4. gregr

    gregr Well-Known Member

    Joined:
    Jul 30, 2014
    Messages:
    766
    Likes Received:
    851
    I meant plugging into the effects return, but there’s really no point in diagnosing. I’m sure you’re using the amp correctly.
     
  5. South Park

    South Park Well-Known Member

    Joined:
    Sep 14, 2019
    Messages:
    3,843
    Likes Received:
    3,586
    It sounds like you have a bad connection work the tubes and swap them around you might have a bad one plug into the FX loop . Sucks
     
    fitz288 likes this.
  6. vampirion78

    vampirion78 New Member

    Joined:
    Nov 27, 2021
    Messages:
    4
    Likes Received:
    1
    i never used the fx loop return, doesnt suppose to play completely well just in the main guitar input?

    cant power tune it mate , im sure i will loose my warranty that way and thomann gives 3 years of it
     
  7. fitz288

    fitz288 Well-Known Yinzer Gold Supporting Member

    Joined:
    Apr 7, 2020
    Messages:
    4,163
    Likes Received:
    10,687
    Location:
    the Burgh
    Opening the back and making sure the tubes are seated correctly won't hurt the warranty.
    A loose tube or bad tube is the most common problem in any tube amp.
    If you don't have a spare ECC83/12AX7, you should get one to make sure it's not an easy fix and not worth the trouble of a return.
    Tubes can last for decades, or go bad in minutes.

    You could also try a jumper cable between the loop send and return.
    Even if you don't use the loop, this sometimes help isolate where the problem may be.
     
    PelliX and South Park like this.
  8. vampirion78

    vampirion78 New Member

    Joined:
    Nov 27, 2021
    Messages:
    4
    Likes Received:
    1
    amp is already on the way to thomann germany, i called and they informed that any kind of interaction inside the amp by not authorised tech will terminate my 3 year warranty, couldnt risk it, plus i didnt even have to pay shipping so not a single extra euro loss for me, unless they found it "ok" after ispection and send it back as it is lol, i will post again if they found what was wrong after all, it may help others in the future ;)
     
    fitz288 likes this.
  9. gregr

    gregr Well-Known Member

    Joined:
    Jul 30, 2014
    Messages:
    766
    Likes Received:
    851
    It’s simply to determine whether the problem is in the preamp or after preamp.

    I hope the replacement doesn’t give you any trouble.
     
  10. PelliX

    PelliX Well-Known Member

    Joined:
    Jun 16, 2020
    Messages:
    1,595
    Likes Received:
    2,965
    Marshall themselves recommend to replace the valves well within that time frame. Ok, they recommend lots of silly stuff, but I can't imagine Thomann arguing about that. It's arguably less responsible to take a valve amp out of the box after it being shipped and not checking the valves are seated correctly, really. Anyhow, chances your replacement will have the same problem are very low, so enjoy it when it arrives. :)
     
    fitz288 likes this.

Share This Page