Marshall DSL 100H. Tube or head problem?

Discussion in 'Marshall Amps' started by Shawn Martin, Oct 29, 2020.

  1. Shawn Martin

    Shawn Martin New Member

    Joined:
    Oct 29, 2020
    Messages:
    7
    Likes Received:
    12
    Hello all. I recently purchased a used Marshall DSL 100H. I swapped out the pre and power tubes. Sino/Tube Art/Ruby El34's (supposed to be all the same rebadged tube) and a preamp "tone kit" from Doug's. Here is the weird thing that's happening. The pair on the left can be biased anywhere from 50mV on up. The pair on the right can only go as cold as 69-70mV. Adjustment screw is maxed out in the cold direction. So, I swapped sides. The pair THAT WAS on the left are now on the right and they will only go as low as 69-70mV now. So it sounds like an amp issue. BUT! I put the stock Marshall tubes back in and both sides can go as low as 50mV. So, not the amp, now? I'm not saying i want to bias it at 50mV, but I cant get the right side colder than 69mV even if i wanted to. The Marshall tubes allow me to go colder though. I've swapped these tubes multiple times with the same outcome. Does the amp just not like these Chinese tubes or what.. Any help??
     
    Last edited: Oct 29, 2020
    Mitchell Pearrow likes this.
  2. Mitchell Pearrow

    Mitchell Pearrow Well-Known Member VIP Member

    Joined:
    Jul 2, 2018
    Messages:
    12,181
    Likes Received:
    22,038
    Location:
    Moreno Valley CA
    Welcome to the forum
    Be patient others here with more knowledge than I will be along to help you with your questions.
    Cheers
    Mitch
     
    Shawn Martin likes this.
  3. JP2036

    JP2036 Member

    Joined:
    Aug 7, 2020
    Messages:
    38
    Likes Received:
    36
    Doug's was your first mistake.
     
  4. Shawn Martin

    Shawn Martin New Member

    Joined:
    Oct 29, 2020
    Messages:
    7
    Likes Received:
    12
    I didn't buy from him, I just saw what was in the preamp tube kit and ordered the exact same tubes from Tubes for Amps because they were $20 bucks cheaper for the exact same tubes. Should've worded it different. And he was kind of an ass when I emailed him with questions early on. One word answers and very uninterested in my business. Oh well.
     
  5. Raymond Toomey

    Raymond Toomey New Member

    Joined:
    Nov 12, 2020
    Messages:
    1
    Likes Received:
    1
    Hello
    Anyone out there who could tell me what to check first on my Dsl 100 h
    it starts great and then it will fade out then back then out and stay very low tone
    thanks Brent
     
    Mitchell Pearrow likes this.
  6. Shawn Martin

    Shawn Martin New Member

    Joined:
    Oct 29, 2020
    Messages:
    7
    Likes Received:
    12
    Might want to start your own thread instead of in this one, since your problem is unrelated. No one is going to see your problem unless they first read mine.
     
    Mitchell Pearrow likes this.
  7. pedecamp

    pedecamp Well-Known Member

    Joined:
    Dec 7, 2009
    Messages:
    15,625
    Likes Received:
    13,492
    Nothing wrong with your amp it's the tubes, send them back to the supplier, tell them what's going on and they will replace them with better matched tubes.
     
    Mitchell Pearrow likes this.
  8. Mitchell Pearrow

    Mitchell Pearrow Well-Known Member VIP Member

    Joined:
    Jul 2, 2018
    Messages:
    12,181
    Likes Received:
    22,038
    Location:
    Moreno Valley CA
    Sounds like a preamp tube, take a known good one and put it in the first slot and see if the problem persists, move it along the rest of the slots to rule this out as the problem first..
    And Welcome To The Forum !!

    Mitch
     

Share This Page