Marshal Valvestate 2000 AVT100 mains transformer

jhilton

New Member
Joined
Apr 1, 2022
Messages
2
Reaction score
0
Hi all, it looks like the mains transformer on my AVT100 is bad.

There was a burning smell and the main fuse in the amp went (the T1.6AL one that is in-between mains in live and the transformer primary coil).

I suspect there is an issue in the primary coil. I have disconnected the cap in the transformer and measured the resistance of the primary coil at just 12.1 ohms! To be honest I was expecting more as that would imply 19amps could flow given V=IR. Given the fuse value is 1.6A I would expect the resistance to be at least 144 ohms (230v mains here).

I'm good with electronics but not transformers. Does V=IR apply in a transformer and should the resistance be at least 144 ohms, as just 12.1 doesn't sound right to me.

Assuming it is the transformer primary coil is it possible to get replacement ones? The transformer has TXMA 00105 D2841 on it (made by Dagnall Electronics Ltd). Input is 0/230V and outputs are 18V/0V/18V and 32V/0V/32V. It doesn't say the VA rating on the transformer though. A quick search on google suggests it isn't a standard one.

What do people do for replacement mains transformers, can you get spares or do you substitute with an alternative that has the same ratings/voltage taps?

Thanks in advance!
 

jhilton

New Member
Joined
Apr 1, 2022
Messages
2
Reaction score
0
As an update I had a reply from Marshall support today to say that they do not have a spare transformer for the model in stock any more, so that avenue is now closed. I guess it is down to a 3rd party options in some form now.
 

Gunner64

Well-Known Member
Gold Supporting Member
Joined
Nov 16, 2013
Messages
7,976
Reaction score
12,191
Location
Midwest, USA
I have 2 150h transformers in storage somewhere here, I don't know the part number as I dont have them handy at the moment, but see if they're the same. I'd give you one for cost of postage if so.
 

Latest posts



Top