MA50h not switching channels

Discussion in 'Marshall Amps' started by Dys, Aug 1, 2020 at 7:06 PM.

  1. Dys

    Dys New Member

    Joined:
    Nov 23, 2018
    Messages:
    3
    Likes Received:
    0
    Hi all.
    I have a MA50h that will not switch channels.
    The LED’s on the amp change but the sound stays clean.

    ie: switch to OD channel lights change from green to red as it should but the sound remains clean. This also happens with the boost channel.

    Happens if I use the panel buttons or the footswitch..

    Any ideas???
     
  2. K2JLX

    K2JLX Well-Known Member

    Joined:
    Apr 20, 2018
    Messages:
    344
    Likes Received:
    690
    Location:
    New York
    I’ve seen a similar issue on the 2205 and 2210s, which turned out to be channel switching transistors. Might be worth looking into if you have a schematic or take it to a qualified tech/Marshall service centre.
     
    scozz likes this.
  3. Dys

    Dys New Member

    Joined:
    Nov 23, 2018
    Messages:
    3
    Likes Received:
    0
    thanks for a place to start..
    They all appear to be standard NPN bipolar transistors in that section BC182 to be exact.

    found schemes online for it, but I’ll Have to dive in and open her up in the morning and have a look, some of them must be working fine because the also serve in the led switching it seems looking at the schematics.
    Might try to probe the audio trace?

    I’ll report back.
    Once again thanks for your help :)
     

Share This Page