Drop in output

Discussion in 'Marshall Amps' started by Dan Smith, Oct 26, 2021.

  1. Dan Smith

    Dan Smith New Member

    Joined:
    Jun 12, 2019
    Messages:
    3
    Likes Received:
    2
    For the past month I have been experiencing a huge drop in output with my 2525H. Usually lasts for about a minute or so. Sometimes it just recovers, other times the sound gets fuzzy or scratchy before it normalizes. I am playing straight into the amp (no pedals). Checked all cables (power, instrument and speaker).

    Thanks for any input.
     
    tce63 likes this.
  2. AlvisX

    AlvisX Garage Guerrilla Gold Supporting Member

    Joined:
    May 31, 2011
    Messages:
    5,789
    Likes Received:
    13,078
    Location:
    I-55 Corridor
    Does that amp have an effects loop ?
    If so , clean the jacks and put a jumper in it
     
  3. PelliX

    PelliX Well-Known Member

    Joined:
    Jun 16, 2020
    Messages:
    1,229
    Likes Received:
    2,134
    Sounds like a valve warming up? Check/replace your preamp valves, one at a time. Could be a lot of things, like a dodgy contact for a heater pin of a valve or whatnot, but let's start easy.

    EDIT: Manners. :welcome:
     
    Jethro Rocker likes this.
  4. tce63

    tce63 Well-Known Member Gold Supporting Member

    Joined:
    Aug 6, 2018
    Messages:
    2,166
    Likes Received:
    6,039
    Location:
    Sweden
    First :welcome: to the forum.

    I had a Origin doing the same thing and it was the Power tubes.

    Good luck

    Cheers :cheers:
     
    PelliX likes this.
  5. pedecamp

    pedecamp Well-Known Member

    Joined:
    Dec 7, 2009
    Messages:
    17,978
    Likes Received:
    18,103
    Do you have some spare power tubes, try that.
     

Share This Page