Design issues/flaws summarized please for JVM205H and JVM410H

Doug Taylor

New Member
Joined
Jul 22, 2017
Messages
28
Reaction score
8
Location
218 Bennington Drive
Is there any place on here where the Marshall Tech folks SUMMARIZE the design flaws or issues that arise after the purchase? Too many guitar players are complaining about things from hissing to tube/tone break up to early on the "clean" channel for both the JVM205H & JVM410H. Has Marshall issued any field service updates on these issues. Does anyone know?
 

pedecamp

Well-Known Member
Joined
Dec 7, 2009
Messages
18,988
Reaction score
20,420
Is there any place on here where the Marshall Tech folks SUMMARIZE the design flaws or issues that arise after the purchase? Too many guitar players are complaining about things from hissing to tube/tone break up to early on the "clean" channel for both the JVM205H & JVM410H. Has Marshall issued any field service updates on these issues. Does anyone know?
Do you have one of these amps, are you experiencing any problems?
 

MonstersOfTheMidway

Well-Known Member
Joined
May 1, 2008
Messages
5,521
Reaction score
3,753
Is there any place on here where the Marshall Tech folks SUMMARIZE the design flaws or issues that arise after the purchase
I'd say that the only place where credible "tech folks" got together to talk about the things they do and don't like with the JVM4 and JVM2 series amps was the JVM Forum. Since that no longer exists, there's really no central resource where all those people come together.

You could try non-Marshall amps forums to find people talk about "design flaws" and "issues" about the JVM. Most non-Marshall amps forums do a pretty good job of beating up on all Marshalls.


Too many guitar players are complaining about things from hissing to tube/tone break up to early on the "clean" channel for both the JVM205H & JVM410H.
I don't know where you're referencing the "too many guitar players are complaining" talk, but that's new to me. Even when the JVM Forum existed, I'd not characterize the site as filled with overwhelming/"too many" complaints. I mean, even in the real world I've not come across a large discontent with the JVM4 and JVM2. Hissing? Either the amp is screwed up or the player is using excessive settings. "Tube/tone break up to early on the clean channel"? What does that mean? tThere are several modes in the clean channel, so you or your sources have to be more specific. Again, maybe a settings issue or a screwed up amp that needs tech work, but hard to say without more detail. Or perhaps all that means is that the JVM2 and JVM4 amps are just not right for some people.:shrug:

Has Marshall issued any field service updates on these issues. Does anyone know?
Field service updates? I have to say no. Maybe not enough people are complaining, though.:shrug:
 

spacerocker

Well-Known Member
Joined
Feb 6, 2009
Messages
1,835
Reaction score
1,490
Location
UK
I don't think there are many genuine "Design Flaws" or field service issues with the JVM series...The only real "service fix" was the deletion of the heater fuses on very early 2009 Models...

Other that that, the amp "is what it is" - a reliable, extremely versatile modern amp, with high-gain capabilities.....A lot of people mod them (me included) to suit their preferences better - but this is not really to fix any inherent design flaws...

The only thing that comes close to a design flaw in my opinion, is the (deliberate) omission of the volume control on the 50W JVMS clean green mode....This means that if you have the "Gain" up high for your Crunch Orange and Red modes, then clean green is deafening! I have a mod to re-introduce the volume control, and another one I did to convert Clean Green to Crunch green - which suits me better.....
 

pedecamp

Well-Known Member
Joined
Dec 7, 2009
Messages
18,988
Reaction score
20,420
I havent heard of "design flaws" with the JVM but with any amp there's always lots of mods available which the JVM has its share.
 

jimmyo

Active Member
Joined
Nov 20, 2021
Messages
79
Reaction score
225
Location
California
I have a JVM 410h and 205h and haven’t had any issues other than the tube changes and pot cleanings you expect with any tube amp. Most of the mods etc posted for these amps are to fine tune the tones for personal preferences but no major design ‘flaws’ that I can think of.
 

Leonard Neemoil

Well-Known Member
Joined
Jun 21, 2021
Messages
1,392
Reaction score
4,247
I'll beat the dead horse again with my JVM gripe. The sound cuts out for a split second when switching channels.
 

Latest posts



Top