Bugera 1960 Infinium #4 tube light permanently on/flashing with brand new tubes

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
Bought a Bugera 1960 Infinium brand new in 2018 for $399 off Sweetwater, bought it for it's value - really good sounding amp, replaced the EL34s with brand new JJs twice now. Also replaced the power tubes with JJs.

I noticed that pretty much since I got the amp the #4 tube light has always been flashing/on about a year in, never really paid too much attention and just assumed that the tubes needed to be replaced because they were about 1 year old at that point and still sounded super good.

Now, however, the lights still on with brand new JJ tubes and the amp doesn't sound as good as it used to and if you turn it up past vol 2 it tube distorts hard while before you could get up to vol 5-6 and still be pretty clean.

I think the amp is still covered under the Sweetwater 3 yr warranty I selected, but I'd have to double check.

Since it's not tubes, what might be wrong with the thing?

Cab is a 94' JCM900 w/ G12T-75s I got for $400 used
 

scozz

Well-Known Member
Gold Supporting Member
Joined
Jul 20, 2008
Messages
5,949
Reaction score
14,075
Umm, you’ve got this in the wrong section, should be in ‘Other Amps’ section.

Or maybe the ‘Workbench’ section.
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
Umm, you’ve got this in the wrong section, should be in ‘Other Amps’ section.

Or maybe the ‘Workbench’ section.

Oh my bad, assumed since it's a 1959 circuit copy I could just stick it here, I don't see a button to delete the thread
 

scozz

Well-Known Member
Gold Supporting Member
Joined
Jul 20, 2008
Messages
5,949
Reaction score
14,075
No worries, a moderator will move it if necessary.
 

Chris-in-LA

Well-Known Member
Joined
Jul 19, 2018
Messages
3,262
Reaction score
3,335
Location
Los Angeles
Sounds like you need a tech to go through it, especially if it’s still under warranty.
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
Sounds like you need a tech to go through it, especially if it’s still under warranty.
Yup, that's the plan, I have the receipt. Turns out I actually got it from Guitar Center not Sweetwater and selected the 3 year warranty which was a good call on my part haha

So I'll just take it up to my local Guitar Center and have em take a look at it
 

Adieu

Well-Known Member
Joined
Jan 12, 2013
Messages
2,822
Reaction score
2,934
Have you tried rotating the tubes? Or cleaning the socket?

You CAN sometimes replace a faulty tube with a faulty tube, however unlikely. I'm sure it has happened to you before with bad new lightbulbs, same thing possible here.
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
Have you tried rotating the tubes? Or cleaning the socket?

You CAN sometimes replace a faulty tube with a faulty tube, however unlikely. I'm sure it has happened to you before with bad new lightbulbs, same thing possible here.

Yes I tried a little experiment of switching the "faulty #4 tube" with the #2 to see if the #2 light would come on, and after 20 mins of playing the #4 light came back on again with the "non faulty #2 tube" - same issue. So it's definitely something wrong with the amp, I could tear the thing apart and clean the sockets and everything however it's been like this with the light coming on since I got it brand new in 2018 and it's still under warranty so I'll just let the guitar center tech deal with it haha
 

Adieu

Well-Known Member
Joined
Jan 12, 2013
Messages
2,822
Reaction score
2,934
Yes I tried a little experiment of switching the "faulty #4 tube" with the #2 to see if the #2 light would come on, and after 20 mins of playing the #4 light came back on again with the "non faulty #2 tube" - same issue. So it's definitely something wrong with the amp, I could tear the thing apart and clean the sockets and everything however it's been like this with the light coming on since I got it brand new in 2018 and it's still under warranty so I'll just let the guitar center tech deal with it haha

GC tech?

...I see no Bugera and store credit in your future
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
GC tech?

...I see no Bugera and store credit in your future
Haha well I figured I bought it from gc so I'll take it to my local gc to have them warranty it, made a good call on that $60 3yr warranty
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
I'd never heard of this amp. Geez thats a lot of amp for the money

Yeahh it's a really good amp man haha highly suggest checking it out. It's got this Infinium tube tech that auto biases the tubes and allows you to run unmatched as well as different tubes so you can run say a KT66 EL34 EL84 and a 6L6 - no idea how that would sound but it's possible

Also if you're interested here's a recording of mine going from vol 1-10 it's stupid loud but also has a master volume on the back for bedroom playing, was recorded using a phone so the audio quality isn't the best but irl it's a really amazing sounding amp

https://drive.google.com/file/d/18QpI-jbyleVG8cau7f3F5JzYsIhdaf_d/view?usp=sharing - Cabs a 94' JCM900 w/ G12T-75s guitar is a Harley Benton ST-62VT (HB makes insane budget guitars also recommend checking them out)

https://drive.google.com/file/d/1zOeerVtv4luYsIw9FaYMnBdPYaJTbNVs/view?usp=sharing - picture of everything
 

351

Member
Joined
Jun 8, 2021
Messages
93
Reaction score
63
Just play the thing, its a cheesy china amp with some stupid gimmick that doesnt work properly. The amp still works, the gimmick doesnt. The amp sounds different with different tubes becausre the new tubes have more headroom. Go back to el34 and enjoy the amp. Play it.
 

StrummerJoe

Well-Known Member
Joined
May 3, 2021
Messages
3,658
Reaction score
11,275
Bugera is known for dodgy QC. GC has no amp techs.

Too bad, cause they ain't bad when working properly.

Good luck!
 

LionsTheBoss

New Member
Joined
Apr 24, 2021
Messages
12
Reaction score
6
Just play the thing, its a cheesy china amp with some stupid gimmick that doesnt work properly. The amp still works, the gimmick doesnt. The amp sounds different with different tubes becausre the new tubes have more headroom. Go back to el34 and enjoy the amp. Play it.

I'm 16 so I don't have money for a 2000+ actual Super Lead but I can get a $400 Chinese copy. The infinium thing actually works, it auto biases the tubes no prob and does what they say it does

I probably got a faulty unit, the amps actually lost all of it's headroom even with brand new JJs in it. Used to need to go up to vol 6 before you got any break up, now it's just screwed up and is breaking up at vol 1 so I'm just gonna warranty it, there's no downside to doing that

Despite what you might have heard, they're pretty sick for the money
 

Dogs of Doom

~~~ Moderator ~~~
Staff Member
Joined
Aug 2, 2012
Messages
27,574
Reaction score
38,429
Location
Los Angeles
I'm 16 so I don't have money for a 2000+ actual Super Lead but I can get a $400 Chinese copy. The infinium thing actually works, it auto biases the tubes no prob and does what they say it does

I probably got a faulty unit, the amps actually lost all of it's headroom even with brand new JJs in it. Used to need to go up to vol 6 before you got any break up, now it's just screwed up and is breaking up at vol 1 so I'm just gonna warranty it, there's no downside to doing that

Despite what you might have heard, they're pretty sick for the money
they're all faulty units...

that's why they are so cheap!

good luck though, I'd definitely put that warranty to work!
 

Pete Farrington

Well-Known Member
Joined
Jan 18, 2021
Messages
1,330
Reaction score
1,428
Location
Staffordshire UK
How about when it fails outside its warranty?
Given its complexity and lack of service info or capability, it’s likely to turn it into boat anchor.
I suppose it may have some ‘spares or repairs’ chassis and iron value as turretboard project.
 

Latest posts



Top