All Vintage or not? '74 JMP

zoso7227

New Member
Joined
Nov 7, 2008
Messages
5
Reaction score
0
Location
Chicago Illinois
Hey guys, I'm extra new to these type of things. I apologize if this thread seems pretty newbish. I just picked up this '74 marshall jmp at guitar center from another state and they shipped it to me and said it was all original. I paid 1700 for it. It seems to have all the vintage parts from my point of view, but i'm not an expert like most of you. I tried to get a pic of the transformers the best that I could. It seems that when I plug it into the first channel, the volume 2 channel seems to work as well. I can turn the volume two to zero though, and it works fine. It just seems to be a bit bassey. Of course the second channel is darker anyways. Just wondering if this is normal for these amps. Any help would be appreciated. Thanks:slash:
 

Attachments

  • 20140227_112732.jpg
    20140227_112732.jpg
    101.2 KB · Views: 47
  • 20140227_112825.jpg
    20140227_112825.jpg
    93.5 KB · Views: 32
  • 20140227_112836.jpg
    20140227_112836.jpg
    92.2 KB · Views: 19
  • 20140227_112841.jpg
    20140227_112841.jpg
    94 KB · Views: 20
  • 20140227_112944_Richtone(HDR).jpg
    20140227_112944_Richtone(HDR).jpg
    94.5 KB · Views: 26

Jaymz E

Well-Known Member
Joined
Sep 11, 2012
Messages
1,466
Reaction score
591
I have an early '74 too, except mine is a 100 watt. It came with 6550 tubes when it was new, I had it switched to el34s, which I think is the way a Marshall should be. I would rather have the 50 watt head over the 100 watt.
 

Jaymz E

Well-Known Member
Joined
Sep 11, 2012
Messages
1,466
Reaction score
591
Try a Y cable and use both channels together.
 

Marshallhead

Well-Known Member
Joined
Jun 3, 2009
Messages
1,444
Reaction score
629
Well that's not an original power transformer. Rest looks ok though.
 

zoso7227

New Member
Joined
Nov 7, 2008
Messages
5
Reaction score
0
Location
Chicago Illinois
Yeah I like the 50 watt. It's more than enough for me. I just thought it might be modded because when I plug into channel 1 by itself, I can increase Volume II and get a more bassey sound. I tried the both channels and it still sounds a bit different than them both at full volume but neither being jumped together.
 


Top