Search results

  1. Silverburst

    Sudden volume drop, restart amp and volume is back?

    After a long servicing thread on my JCM800 2205 '88 I've had a lot of fun with this amp and enjoy it a lot. Did quite some preamp tube rollin' to get the best combination I could come up with, which also helped me cancelling out some static issues I was having. Amp is well biased via internal...
  2. Silverburst

    SV20H vs Attenuated 1987 / 1959

    To get the goods from a sv20 you need an attenuator anyway. 50w and 100w counterparts always sound bigger and have more authority, even attenuated. I have both an sv20 and 1980 superlead. That being said, Marshall did a tremendous good job on the studio series getting the real characteristics in...
  3. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    ah, this one is a "Julie" ;)
  4. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    What exactly is a "Nick" 2205? :hmm:
  5. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Anyone could confirm this? @RickyLee , you used to turn your 2205 inside out if I remember correctly and used to have voltage charts I believe. Could you chime in? Thx!
  6. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    I finally found the culprit with a fresh mind this morning! :fever: For the sale of future problems other members might come across, here are my notes of my n00b amp mind going through the process lol: As @Pete Farrington mentioned, check voltages and where it is off in fault mode it should be...
  7. Silverburst

    Is DSL100HR being discontinued?

    prices are back up to their old. darn, should I've gone for it...
  8. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Because the feeding wire indeed feeds 2 pins/filaments? Yeah they are. if you move the wires or tubes, the whole sockets wiggles. PI has already been replaced.
  9. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    @Pete Farrington I did full measurement in fault (grey notes at top) and working mode (blue notes at bottom). This time fiddling around v4 triggered the problem a few times, but it is quite hard to replicate. Now I can do what I want and the amp keeps working. can't get it into fault mode...
  10. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Something else I wondered. these are the 2 remaining components I didn't replace yet in the bias circuit. these 22nF caps look kinda 'smokey' compared to all other white Wima caps on the board. I that a sign of wear/heat over time?
  11. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Thx Pete, I was thinking in that direction, but if a tube isn't "heated", doesn't it stop glowing? It kept glowing in fault mode...
  12. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    captain's log: When I fiddle with a chop stick around the PI socket connections, I had a few times volumes swells down over a few seconds.... then I fiddle a bit further over there for a few minutes and the volume swells back up again. can't pinpoint the culprit yet but it must be over there...
  13. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    hmmm... volume gone again... there must be some bad contact elsewhere...
  14. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Ok, think I got it! went in to replace the 2 ugly resisitors because that wouldn't hurt anyways, and noticed one was actually a bit loose on one legg. when I aplied some pull with my pliers it came right out. Looks cleaner now. Thanks so much for all your help. Going to check the other tubes...
  15. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    All contacts and tube sockets cleaned with kontakt60, reflowed suggested pins -> no effect pin 4 : 430v on both tubes pin 6 : 436v on both tubes Initially, before power tubes went bad and fried HT fuse, I did not have any volume problems btw.
  16. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Thanks! Tested the return and I get zero volume over there, even with master on 10. Then I went back to the front input and also there, the master has no effect whatsoever. All the volume seems to be coming from the channel volumes. Even with the master at zero, I hear the same slight volume as...
  17. Silverburst

    Bias & Volume troubleshooting on my NAD '88 JCM800 2205

    Ok, I got a small step further. Apparently both tube sets I was testing with were defect! :eek: Before I went in to replace all suspicious bias parts, I tested one last time with other tubes and in the meantime a 1ohm resistors installed at the pin 8k cathode to rule out any strange things with...
  18. Silverburst

    Best soldering iron for pots

    As mentioned any real Hakko should be fine but get temperatures above 700 and use a wide solderin tip for better and faster heat transfer. Generally it is also better to heat short and hotter than longer and less hot to save components, pcb etc afaik.
  19. Silverburst

    Is DSL100HR being discontinued?

    hmmm, might be response to evh 5150 iconic price point?
  20. Silverburst

    Is DSL100HR being discontinued?

    Sheesh, less then 500€... that is really cheap and hard to resist for a 100w full tube amp with so many options....

Latest posts



Top