Search results

  1. M

    JCM 900 4100model - caps and rebuild advice

    This is a NA model with a 4A slo blo fuse. It won't blow in stand-by; but, about 8 seconds after switch on it fails. My thinking was the filter caps. And yes, excellent advice and thanks for steering me there without solving the problem for me.
  2. M

    JCM 900 4100model - caps and rebuild advice

    Thank you sir. 40 Watt bulb. I will check the voltages.
  3. M

    JCM 900 4100model - caps and rebuild advice

    Fails after first tube goes in, within 8 seconds. Light bulb starts to glow brighter, then....loud buzz as before and fuse blows.
  4. M

    JCM 900 4100model - caps and rebuild advice

    I built light bulb limiter today and tested the amp without any output tubes. Fuse OK. Now to the nervous part; move on and put back one tube at a time. I'll post news after I dig up some bravery.
  5. M

    JCM 900 4100model - caps and rebuild advice

    Thanks for the advice. There's always "one of you" around forums
  6. M

    JCM 900 4100model - caps and rebuild advice

    I have seen the light bulb used in radio circuits. Great idea.
  7. M

    JCM 900 4100model - caps and rebuild advice

    1997 amp. There are no hotspots anywhere on any pcbs. All of the caps look original and new. No swelling or leaking. I tested all of the tubes with a tube tester and are in great shape. The mains fuse will blow after 5-6 seconds of power on. I think I should recap it. Check resistors. What would...

Latest posts



Top