Jcm800 2210 Eq In Efx Loop

Discussion in 'Marshall Amps' started by stilllifer, Jan 7, 2019.

  1. stilllifer

    stilllifer Active Member

    Joined:
    Jan 2, 2013
    Messages:
    560
    Likes Received:
    238
    Location:
    Somewhere in Time
    Good day and Happy belated New Year to everyone!
    I have an '89 2210 and after watching Johan Segeborn's video of his 1987x, I knew I needed to try it.
    Now I bought a pretty inexpensive 7 band chinese Ammoon EQ just to try it out. Johan was using an outboard API EQ that is almost as expensive as the head, so I know my limitations!
    I am getting big popping noises when I turn the pedal on and a hiss. I am not sure if this is the cheap pedal or not.
    Nothing else in the loop - just the EQ pedal, using good quality patch cables. I have a separate pedalboard using the input on the front of the head as usual.
    Any ideas why this would be popping? Anyone else use an EQ in their loop with success?

    Thanks,
    Geoff
     
  2. Ufoscorpion

    Ufoscorpion Well-Known Member

    Joined:
    May 4, 2013
    Messages:
    1,743
    Likes Received:
    1,480
    Stick a patch cable between the send and return , if it's as quiet as usual then it's the pedal .
     
  3. stilllifer

    stilllifer Active Member

    Joined:
    Jan 2, 2013
    Messages:
    560
    Likes Received:
    238
    Location:
    Somewhere in Time
    Doh! I should have thought of that. It's the pedal for sure. Cheers.
     
    Ufoscorpion and tce63 like this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice