jcm 800 reverb issues

Discussion in 'The Workbench' started by Exotic, Nov 10, 2019 at 4:51 PM.

  1. Exotic

    Exotic Active Member

    Joined:
    Sep 3, 2018
    Messages:
    217
    Likes Received:
    106
    my jcm 800 2210 is in the shop and the guy doesn't know whats wrong ,right before it happened i had been wiring speakers into cabs ,so i thought maybe i did it ,but now i don't think so because my dmm's are giving me good readings on all 3 cabs as they should be(2 8 ohm cabs 1 16 ohm cab) . and the amp still functions ,but the symptoms are only these : the amp howls when not in use,but turned on (toggle switch in off position of guitar plugged in) ,the reverb potentiometer is not acting right ,when it is on any other position except 8 the volume is up too high even with the master on 0 ,when u turn the reverb to 8(8 is the position i always have it set to ) it quiets down .
    i want the pot replaced ,but the tech said he cleaned it and they might be scratchy but not in need of replacement .
    i'm ready to pick it up and take it elsewhere ,i need my head back ! i just spent 700 dollars on 2 jbls d120f's and 1 greenback and 1 evh speaker!
    he says the problem is intermittent ,somtimes the sound happens sometimes it doesn't . i'm going to tell him to check for output transformer ,faulty component in the reverb ,microphonic preamp tube . bad output or power supply . cracked solder joints . any other ideas?
     
  2. ampmadscientist

    ampmadscientist Well-Known Member

    Joined:
    Jun 26, 2014
    Messages:
    13,811
    Likes Received:
    7,657
    Location:
    Start the reactor... Free Mars!
    Cleaning the reverb pot usually fixes the control problem. It is not usually necessary to replace the pot.

    The howling can be caused by a corroded low input jack which is common on these models.
    Plugging into the LOW jack the noise will stop.
     
  3. Exotic

    Exotic Active Member

    Joined:
    Sep 3, 2018
    Messages:
    217
    Likes Received:
    106
    IMG_1459 (Custom).JPG the jcm 800 2210 only has one input ,but thanks : )
     
    Last edited: Nov 10, 2019 at 10:57 PM
  4. CoyotesGator

    CoyotesGator Well-Known Member

    Joined:
    Jul 31, 2012
    Messages:
    1,803
    Likes Received:
    1,498
    Location:
    The Institute for the Very, Very, Very Nervous
    Foot switch and or cable problem?
     
  5. ampmadscientist

    ampmadscientist Well-Known Member

    Joined:
    Jun 26, 2014
    Messages:
    13,811
    Likes Received:
    7,657
    Location:
    Start the reactor... Free Mars!
    he says the problem is intermittent ,somtimes the sound happens sometimes it doesn't .

    If you take out V1 preamp tube (tube closest to the input jack) does the noise stop?

    Are you able to check or re-solder the input jack for possible cracked connections?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice