Haze Mhz40c Assistance Required

Discussion in 'Marshall Amps' started by primed73, Nov 19, 2017.

  1. primed73

    primed73 New Member

    Joined:
    Nov 19, 2017
    Messages:
    6
    Likes Received:
    1
    Good evening,

    I've seen plenty of very old threads on the subject of this amp regarding issues with channel popping when the dsp reverb is on etc. (didn't want to wake up old threads).

    Does anyone have a copy of the CATS-00163 document that details the replacement of the resistors and caps for fixing this issue?

    I've seen in previous threads the values of the resistors that were replaced, but not the capacitor values, just the capacitor numbers.

    Cheers,
    Gary.
     
  2. primed73

    primed73 New Member

    Joined:
    Nov 19, 2017
    Messages:
    6
    Likes Received:
    1
  3. Micky

    Micky Well-Known Member VIP Member

    Joined:
    Apr 29, 2010
    Messages:
    18,540
    Likes Received:
    14,362
    Location:
    Vermont
  4. primed73

    primed73 New Member

    Joined:
    Nov 19, 2017
    Messages:
    6
    Likes Received:
    1
    Thanks for the reply Micky, greatly appreciated!

    R100 is not installed with a 220k resistor though R90 and R101 are close to 1m.
    I had seen somewhere that a few caps were replaced too, can't see what the values were though.
     
  5. primed73

    primed73 New Member

    Joined:
    Nov 19, 2017
    Messages:
    6
    Likes Received:
    1
    I have looked around and found and replacements for C33, C60, C68 and C70 were a part of the fix.
    On the schematic they are all 22nf 400v caps, does anyone know what they were replaced with?
    Original values or updated values?
     
  6. primed73

    primed73 New Member

    Joined:
    Nov 19, 2017
    Messages:
    6
    Likes Received:
    1
    Scratch that, they are like for like replacements, did a little more digging.
     

Share This Page