MarshallForum.com
 
Go Back   MarshallForum.com > The Amps > Marshall Amps
Heritage Guitar Talk - Click here! LIKE MarshallForum on Facebook FOLLOW MarshallForum on Twitter
  
Reply
LinkBack Thread Tools Display Modes
Unread 03-22-2009, 11:56 PM   #1 (permalink)
Super Moderator
 
MartyStrat54's Avatar
 
Join Date: Feb 2009
Location: Now in Muskogee, by Tulsa
Posts: 26,193
Send a message via Yahoo to MartyStrat54
Exclamation Need Bias Values For A JTM60!!! EL34's!!!

Hello: Marty here. I'm trying to help out cudamax2343. He's got a JTM60 head and he is wanting to bias a set of tubes in the head. Is the bias the same as other 600 series heads? My TSL602 is biased at 80mV (40mV each tube).

Does any of you other techs know what the bias value is for this amp? I can't find it anywhere. Not even on Dr. Tube.

Also, it appears that unlike my TSL 602, there is only one neutral test point and one hot test point, instead of a hot-neutral-hot found on my 602. Is that correct? I've never worked on a JTM60 head and I am just trying to get cuda going down the road...safely. I don't want him burning any tubes.

Help us if you can.

Marty
MartyStrat54 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:19 AM.


Find us on Facebook!   Follow us on Twitter!

Our Network: PRS Guitar Forum | Luthier Forum | SG Guitar Forum | Les Paul Forum | Music Gear Forum | 7 String Guitar Forum | Acoustic Guitar Forum

MarshallForum proudly supports St. Jude Children's Research Hospital

Copyright © 2005-2014, MarshallForum.com. All Rights Reserved.